miércoles, 21 de julio de 2010

Lab MPLS 1.9 QOS MPLS

Sección 8: QOS

· El trafico desde el ID R9 al ID R10 debe ser marcado con valor EXP 5 EF(Express Forwarding)

· El resto del tráfico debe ser marcado con el valor EXP 2




Ejemplo 7-1
─────────────────────────────────────────────────────────────────

R4
access-list 100 permit ip host 100.0.0.10 host 100.0.0.9

class-map match-all EF
description **desde CE-R10**
match access-group 100

class-map match-all EXP5
description **desde P-R1**
match mpls experimental topmost 5

class-map match-all G5
match qos-group 5

class-map match-all EXP2
description **desde P-R1**
match mpls experimental topmost 2

class-map match-all G2
match qos-group 2

policy-map desde_CE
class EF
set qos-group 5
set mpls experimental imposition 5

class class-default
set qos-group 2
set mpls experimental imposition 2

policy-map hacia_P
class EXP5
priority 640
class EXP2
bandwidth 1000
random-detect

policy-map desde_P
class EXP5
set qos-group 5
class EXP2
set qos-group 2

policy-map hacia_CE
class G5
priority 640
class G2
bandwidth 1000
random-detect

interface FastEthernet0/0
service-policy input desde_CE
service-policy output hacia_CE
interface FastEthernet0/1
service-policy input desde_P
service-policy output hacia_P

R1
class-map match-all EXP5
match mpls experimental topmost 5
class-map match-all EXP2
match mpls experimental topmost 2

policy-map hacia_PE-R3
class EXP5
priority 640
class EXP2
bandwidth 1000
random-detect

policy-map hacia_PE-R4
class EXP5
priority 640
class EXP2
bandwidth 1000
random-detect

interface FastEthernet1/0
service-policy output hacia_PE-R4

interface FastEthernet0/1
service-policy output hacia_PE-R3


R3
access-list 100 permit ip host 100.0.0.9 host 100.0.0.10

class-map match-all EF
match access-group 100

class-map match-all G2
match qos-group 2

class-map match-all G5
match qos-group 5

class-map match-all EXP5
match mpls experimental topmost 5

class-map match-all EXP2
match mpls experimental topmost 2

policy-map hacia_P-R1
class EXP5
priority 640
class EXP2
bandwidth 1000
random-detect

policy-map desde_P-R1
class EXP5
set qos-group 5
class EXP2
set qos-group 2

policy-map hacia_CE
class G5
priority 640
class G2
bandwidth 1000
random-detect

policy-map desde_CE
class EF
set qos-group 5
set mpls experimental imposition 5
class class-default
set qos-group 2
set mpls experimental imposition 2

interface FastEthernet0/1
service-policy input desde_P-R1
service-policy output hacia_P-R1

interface FastEthernet0/0
service-policy input desde_CE
service-policy output hacia_CE

─────────────────────────────────────────────────────────────────

Pruebas QOS
Podemos observar en el traceroute del ejemplo 7-2 que para ambos casos, MPLS utiliza el mismo FEC.

Ejemplo 7-2
─────────────────────────────────────────────────────────────────

R10#traceroute 100.0.0.9
1 172.16.104.4 96 msec 64 msec 40 msec
2 10.1.14.1 [MPLS: Labels 1001/3013 Exp 2] 264 msec 244 msec 168 msec
3 172.16.39.3 [MPLS: Label 3013 Exp 2] 180 msec 136 msec 136 msec
4 172.16.39.9 288 msec * 208 msec

R10#traceroute 100.0.0.9 source loopback 0
1 172.16.104.4 88 msec 52 msec 20 msec
2 10.1.14.1 [MPLS: Labels 1001/3013 Exp 5] 284 msec 236 msec 160 msec
3 172.16.39.3 [MPLS: Label 3013 Exp 5] 116 msec 232 msec 124 msec
4 172.16.39.9 176 msec * 200 msec


R9#traceroute 100.0.0.10
1 172.16.39.3 44 msec 172 msec 16 msec
2 10.1.13.1 [MPLS: Labels 1002/4009 Exp 2] 212 msec 160 msec 160 msec
3 172.16.104.4 [MPLS: Label 4009 Exp 2] 128 msec 140 msec 204 msec
4 172.16.104.10 144 msec * 236 msec

R9#traceroute 100.0.0.10 source 100.0.0.9
1 172.16.39.3 64 msec 132 msec 128 msec
2 10.1.13.1 [MPLS: Labels 1002/4009 Exp 5] 136 msec 208 msec 152 msec
3 172.16.104.4 [MPLS: Label 4009 Exp 5] 176 msec 80 msec 96 msec
4 172.16.104.10 196 msec * 224 msec


R4#show policy-map interface fastEthernet 0/0
FastEthernet0/0

Service-policy input: desde_CE

Class-map: EF (match-all)
24 packets, 1440 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
QoS Set
qos-group 5
Packets marked 24
mpls experimental imposition 5
Packets marked 24

Class-map: class-default (match-any)
126 packets, 10968 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
QoS Set
qos-group 2
Packets marked 126
mpls experimental imposition 2
Packets marked 126

Service-policy output: hacia_CE

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 3/126

Class-map: G5 (match-all)
3 packets, 126 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0


Class-map: G2 (match-all)
23 packets, 2918 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 2
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 23/2918
bandwidth 1000 kbps
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 3/126 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 20/2792 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10

Class-map: class-default (match-any)
19 packets, 3342 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 210/20565



R1#show policy-map interface fastEthernet 0/1
FastEthernet0/1

Service-policy output: hacia_PE-R3

queue stats for all priority classes:

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0

Class-map: EXP5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0


Class-map: EXP2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 2
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0
bandwidth 1000 kbps
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10

Class-map: class-default (match-any)
297 packets, 71304 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 338/29216


R1#show policy-map interface fastEthernet 1/0
FastEthernet1/0

Service-policy output: hacia_PE-R4

queue stats for all priority classes:

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0

Class-map: EXP5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0


Class-map: EXP2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 2
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0
bandwidth 1000 kbps
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10

Class-map: class-default (match-any)
319 packets, 76886 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 267/22935
R3#show policy-map interface fastEthernet 0/0
FastEthernet0/0

Service-policy input: desde_CE

Class-map: EF (match-all)
12 packets, 720 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
QoS Set
qos-group 5
Packets marked 12
mpls experimental imposition 5
Packets marked 12

Class-map: class-default (match-any)
103 packets, 9562 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
QoS Set
qos-group 2
Packets marked 103
mpls experimental imposition 2
Packets marked 103

Service-policy output: hacia_CE

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 6/252

Class-map: G5 (match-all)
6 packets, 252 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
Priority: 640 kbps, burst bytes 16000, b/w exceed drops: 0


Class-map: G2 (match-all)
16 packets, 1648 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 2
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 16/1648
bandwidth 1000 kbps
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 6/252 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 10/1396 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10

Class-map: class-default (match-any)
18 packets, 3324 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 153/15671

No hay comentarios:

Publicar un comentario