miércoles, 21 de julio de 2010

Lab MPLS 1.2 IGP ISP

Sección 1: IGP en Core del Service Provider

· Configurar OSPF 1 Área 0 en los routers R1/R2/R3/R4/R5

· Publicar loopback0 e interfaces física dentro del AS1 (ver Figura β).

· No utilizar el comando network en el proceso OSPF.

· Todos los segmentos del AS1 deben ser OSPF punto a punto.



Podemos publicar redes OSPF de dos modos:

- Dentro del proceso OSPF con el comando network ip-address wildcard-mask area area-id

- En la interface utilizando el comando ip ospf process-id area area-id [secondaries none] (A partir del IOS 12.0(29)S).

No podemos configurar OSPF en el proceso, la única opción disponible es habilitar OSPF en las interfaces de manera similar a OSPFv3 o IS-IS.

El comando de interface ip ospf network point-to-point trata a la interface OSPF como red p2p. Esto evita la elección de un Designated Router (DR), logrando mayor eficiencia. En redes Broadcast con más de dos routers no debemos modificar el tipo de red.


Ejemplo1-1 Configuración OSPF AS1
─────────────────────────────────────────────────────────────────

R1
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

!
interface FastEthernet0/1
ip address 10.1.13.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

!
interface FastEthernet1/0
ip address 10.1.14.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

!
interface FastEthernet2/0
ip address 10.1.15.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

!
router ospf 1
router-id 10.0.0.1
log-adjacency-changes

R2
interface Loopback0
ip address 10.0.0.2 255.255.255.255
ip ospf network point-to-point
ip ospf 1 area 0
!
interface FastEthernet0/1
ip address 10.1.12.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

router ospf 1
router-id 10.0.0.2
log-adjacency-changes

R3
interface Loopback0
ip address 10.0.0.3 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/1
ip address 10.1.13.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

router ospf 1
router-id 10.0.0.3
log-adjacency-changes


R4
interface Loopback0
ip address 10.0.0.4 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/1
ip address 10.1.14.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0


R5
interface Loopback0
ip address 10.0.0.5 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/1
ip address 10.1.15.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0


─────────────────────────────────────────────────────────────────

· Usar loopback 0 como ID OSPF.


El proceso OSPF es capaz de seleccionar el ID, pero es recomendable configurarlo con el comando router-id. En caso de que el proceso OSPF haya seleccionado un ID OSPF y nosotros seleccionamos otro, un aviso nos indicará que los cambios no serán efectivos hasta usemos el comando clear ip ospf process:

Reload or use "clear ip ospf process" command, for this to take effect


Ejemplo 1-1
─────────────────────────────────────────────────────────────────

R1
router ospf 1
router-id 10.0.0.1

R2
router ospf 1
router-id 10.0.0.2
log-adjacency-changes

R3
router ospf 1
router-id 10.0.0.3

R4
router ospf 1
router-id 10.0.0.4

R5
router ospf 1
router-id 10.0.0.5

─────────────────────────────────────────────────────────────────

El comando show ip ospf neighbor entrega información sobre la adyacencia entre vecinos conectados a un segmento (ver Ejemplo 1-2). Puesto que el tipo de red es punto a punto, el proceso OSPF alcanza estado full sin elección de DR.


Ejemplo 1-2 Estado de vecinos OSPF
─────────────────────────────────────────────────────────────────
R1# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.5 0 FULL/ - 00:00:35 10.1.15.5 FastEthernet2/0
10.0.0.4 0 FULL/ - 00:00:38 10.1.14.4 FastEthernet1/0
10.0.0.3 0 FULL/ - 00:00:36 10.1.13.3 FastEthernet0/1
10.0.0.2 0 FULL/ - 00:00:34 10.1.12.2 FastEthernet0/0

R2# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 FULL/ - 00:00:38 10.1.12.1 FastEthernet0/1

R3# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 FULL/ - 00:00:34 10.1.13.1 FastEthernet0/1

R4# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 FULL/ - 00:00:38 10.1.14.1 FastEthernet0/1

R5# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 FULL/ - 00:00:37 10.1.15.1 FastEthernet0/1

─────────────────────────────────────────────────────────────────

Las distintas etapas de OSPF antes de alcanzar el estado full podemos observarlas con el comando debug ip ospf adj. Normalmente este comando suele utilizarse en el proceso de troubleshooting. El ejemplo 1-3 muestra la utilidad del comando cuando la MTU entre vecinos es distinta (R2 tiene la MTU 1400 y R1 el valor MTU por defecto 1500).

R2 y R1 transitan por distintos estados pero nunca alcanzan el estado full. Cuando el tiempo transcurrido llega al dead-interval OSPF establece el estado DOWN. La salida has larger interface MTU indica que no existe acuerdo entre vecinos sobre la MTU. Para corregir el problema reestablecemos el valor a la MTU original.


Ejemplo 1-3 debug ip ospf adj R2
─────────────────────────────────────────────────────────────────
R2(config)# interface fastEthernet 0/1
R2(config-if)# ip mtu 1400

R2# clear ip ospf process
Reset ALL OSPF processes? [no]: yes

R2# debug ip ospf adj
OSPF: Interface FastEthernet0/1 going Down
OSPF: 10.0.0.2 address 10.1.12.2 on FastEthernet0/1 is dead, state DOWN
OSPF: 10.0.0.1 address 10.1.12.1 on FastEthernet0/1 is dead, state DOWN
%OSPF-5-ADJCHG: Process 1, Nbr 10.0.0.1 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
OSPF: Interface Loopback0 going Down
OSPF: 10.0.0.2 address 10.0.0.2 on Loopback0 is dead, state DOWN
OSPF: Interface FastEthernet0/1 going Up
OSPF: Interface Loopback0 going Up
OSPF: 2 Way Communication to 10.0.0.1 on FastEthernet0/1, state 2WAY
OSPF: FastEthernet0/1 Nbr 10.0.0.1: Prepare dbase exchange
OSPF: Send DBD to 10.0.0.1 on FastEthernet0/1 seq 0x1973 opt 0x52 flag 0x7 len 32
OSPF: Rcv DBD from 10.0.0.1 on FastEthernet0/1 seq 0x972 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
OSPF: Nbr 10.0.0.1 has larger interface MTU
OSPF: Rcv DBD from 10.0.0.1 on FastEthernet0/1 seq 0x1973 opt 0x52 flag 0x2 len 112 mtu 1500 state EXSTART

R2# show ip ospf neighbor sorted
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 EXSTART/ - 00:00:39 10.1.12.1 FastEthernet0/1

R2# show ip ospf neighbor sorted
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 DOWN/ - - 10.1.12.1 FastEthernet0/1

R2#
%OSPF-5-ADJCHG: Process 1, Nbr 10.0.0.1 on FastEthernet0/1 from EXSTART to DOWN, Neighbor Down: Too many retransmissions
R2#
%OSPF-5-ADJCHG: Process 1, Nbr 10.0.0.1 on FastEthernet0/1 from DOWN to DOWN, Neighbor Down: Ignore timer expired

R2(config)#interface fastEthernet 0/1
R2(config-if)#ip mtu 1500

R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.0.0.1 0 FULL/ - 00:00:36 10.1.12.1 FastEthernet0/1

─────────────────────────────────────────────────────────────────

El comando show ip ospf interface es otra herramiento útil. Permite conocer una amplia variedad de parámetros OSPF asociados con la interface.

OSPF no es flexible si existen parámentros en ambos extremos que no coinciden, en cuyo caso el proceso no formará adyacencia, por ejemplo el dead-interval, hello, Network Type deben ser iguales entre peers OSPF.

Podemos tener una vision rapida del tipo de red OSPF con el comando show ip ospf interface brief.

Ejemplo 1-4 show ip ospf interface muestra tipo de red, costo y prioridad en las interfaces de R2.
─────────────────────────────────────────────────────────────────

R1#show ip ospf interface fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.12.1/24, Area 0
Process ID 1, Router ID 10.0.0.1, Network Type POINT_TO_POINT, Cost: 1
Enabled by interface config, including secondary ip addresses
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.0.0.2
Suppress hello for 0 neighbor(s)

R1#show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa2/0 1 0 10.1.15.1/24 1 P2P 1/1
Fa1/0 1 0 10.1.14.1/24 1 P2P 1/1
Fa0/1 1 0 10.1.13.1/24 1 P2P 1/1
Fa0/0 1 0 10.1.12.1/24 1 P2P 1/1
Lo0 1 0 10.0.0.1/32 1 LOOP 0/0

─────────────────────────────────────────────────────────────────

No hay comentarios:

Publicar un comentario en la entrada