miércoles, 21 de julio de 2010

Inter-AS RR Multihop 1ª

Inter-AS: Multi-hop MP-eBGP entre route-reflectors (RRs) Option 3 con AS intermedio.
AS1 y AS2 deben entregar servicios VPN L3 entre sitio 1 y sitio 2. Sin embargo no existe comunicación directa entre AS1 y AS2. El desafío es poder comunicar AS1 y AS2 utilizando un AS intermedio (AS100) sin que este deba formar sesión MP-eBGP con AS1 y AS2.
Para lograr el objetivo se deben cumplir dos cosas:
  1. Debe existir un Label Switching Path (LSP) entre los Provider Edges R2 y R7.
  2. Los ID de R2 y R7 deben ser publicados en todos los ASs con sus etiquetas asociadas (transportados por iBGP o por IGP).


Para esta solución hemos dividido la implementación en cinco secciones:

- Sección 1ª IGP/MPLS

- Sección 2ª iBGP

- Sección 3ª eBGP/MP-BGP

- Sección 4ª Instancia VRF. IGP PE-CE. Redistribución IGP <->MP-iBGP.

- Sección 5ª Pruebas entre sitios




Sección 1ª IGP/MPLS

IGP AS1
--------------------------------------------------------------------------
R2
interface Loopback0
ip address 10.0.0.2 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/1
ip address 10.1.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

router ospf 1
router-id 10.0.0.2
log-adjacency-changes
passive-interface Loopback0


R3
interface Loopback0
ip address 10.0.0.3 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/0
ip address 10.1.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

interface FastEthernet0/1
ip address 10.1.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

router ospf 1
router-id 10.0.0.3
log-adjacency-changes
passive-interface Loopback0


R4
interface Loopback0
ip address 10.0.0.4 255.255.255.255
ip ospf 1 area 0

interface FastEthernet0/0
ip address 10.1.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0

router ospf 1
router-id 10.0.0.4
log-adjacency-changes
passive-interface Loopback0

--------------------------------------------------------------------------

Un ping extendido es útil para comprobar conectividad dentro del AS1.

--------------------------------------------------------------------------

R2#sh ip route ospf
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O 10.0.0.3/32 [110/2] via 10.1.23.3, 00:00:49, FastEthernet0/1
O 10.0.0.4/32 [110/3] via 10.1.23.3, 00:00:59, FastEthernet0/1
O 10.1.34.0/24 [110/2] via 10.1.23.3, 00:02:27, FastEthernet0/1


R2#ping 10.0.0.3 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/67/132 ms

R2#ping 10.0.0.4 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.4, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/116/204 ms

--------------------------------------------------------------------------

MPLS AS1
Asignaremos estáticamente las etiquetas MPLS. Para esto debemos mapear los router ID a labels. Por ejemplo en R2 usamos el comando
mpls label range 215 299 static 200 214: El rango de de etiquetas (labels) 215 a 299 es asignado aleatoriamente por el proceso LDP, el rango 200 a 214 es para el mapeo ID-> label que haremos nosotros. Establecer mapeo estático nos ayudará a entender como trabaja MPLS a través del Label Switching Path (LSP).

--------------------------------------------------------------------------
R2
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 215 299 static 200 214
mpls static binding ipv4 10.0.0.3 255.255.255.255 203
mpls static binding ipv4 10.0.0.4 255.255.255.255 204
mpls static binding ipv4 10.0.0.5 255.255.255.255 205
mpls static binding ipv4 10.0.0.6 255.255.255.255 206
mpls static binding ipv4 10.0.0.7 255.255.255.255 207
mpls static binding ipv4 10.0.0.9 255.255.255.255 209
mpls static binding ipv4 10.0.0.10 255.255.255.255 210
mpls static binding ipv4 10.0.0.11 255.255.255.255 211
mpls static binding ipv4 10.0.0.12 255.255.255.255 212

interface FastEthernet0/1
mpls ip


R3
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 315 399 static 300 314
mpls static binding ipv4 10.0.0.2 255.255.255.255 302
mpls static binding ipv4 10.0.0.4 255.255.255.255 304
mpls static binding ipv4 10.0.0.5 255.255.255.255 305
mpls static binding ipv4 10.0.0.6 255.255.255.255 306
mpls static binding ipv4 10.0.0.7 255.255.255.255 307
mpls static binding ipv4 10.0.0.9 255.255.255.255 309
mpls static binding ipv4 10.0.0.10 255.255.255.255 310
mpls static binding ipv4 10.0.0.11 255.255.255.255 311
mpls static binding ipv4 10.0.0.12 255.255.255.255 312

interface FastEthernet0/0
mpls ip

interface FastEthernet0/1
mpls ip


R4
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 415 499 static 400 414
mpls static binding ipv4 10.0.0.2 255.255.255.255 402
mpls static binding ipv4 10.0.0.3 255.255.255.255 403
mpls static binding ipv4 10.0.0.5 255.255.255.255 405
mpls static binding ipv4 10.0.0.6 255.255.255.255 406
mpls static binding ipv4 10.0.0.7 255.255.255.255 407
mpls static binding ipv4 10.0.0.9 255.255.255.255 409
mpls static binding ipv4 10.0.0.10 255.255.255.255 410
mpls static binding ipv4 10.0.0.11 255.255.255.255 411
mpls static binding ipv4 10.0.0.12 255.255.255.255 412

interface FastEthernet0/0
mpls ip


R3#show mpls ldp discovery
Local LDP Identifier:
10.0.0.3:0
Discovery Sources:
Interfaces:
FastEthernet0/0 (ldp): xmit/recv
LDP Id: 10.0.0.4:0
FastEthernet0/1 (ldp): xmit/recv
LDP Id: 10.0.0.2:0
--------------------------------------------------------------------------

Cuando se forme el LSP PE a PE obtendremos etiquetas en el campo Otgoing

Labels, mietras veremos No Label salvo para los prefijos ID de los LSRs que

pertenecen al propio AS.


--------------------------------------------------------------------------
R2#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
203 Pop Label 10.0.0.3/32 0 Fa0/1 10.1.23.3
204 304 10.0.0.4/32 0 Fa0/1 10.1.23.3
205 No Label 10.0.0.5/32 0 drop
206 No Label 10.0.0.6/32 0 drop
207 No Label 10.0.0.7/32 0 drop
209 No Label 10.0.0.9/32 0 drop
210 No Label 10.0.0.10/32 0 drop
211 No Label 10.0.0.11/32 0 drop
212 No Label 10.0.0.12/32 0 drop
215 Pop Label 10.1.34.0/24 0 Fa0/1 10.1.23.3

R2#show mpls forwarding-table | e No L
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
203 Pop Label 10.0.0.3/32 0 Fa0/1 10.1.23.3
204 304 10.0.0.4/32 0 Fa0/1 10.1.23.3
215 Pop Label 10.1.34.0/24 0 Fa0/1 10.1.23.3

R2#show mpls label range
Downstream Generic label region: Min/Max label: 215/299
Range for static labels: Min/Max label: 200/214

--------------------------------------------------------------------------

Repetimos el mismo procedimiento IGP + MPLS en AS2 y AS100.

IGP + MPLS en AS2
--------------------------------------------------------------------------
R5
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 515 599 static 500 514
mpls static binding ipv4 10.0.0.2 255.255.255.255 502
mpls static binding ipv4 10.0.0.3 255.255.255.255 503
mpls static binding ipv4 10.0.0.4 255.255.255.255 504
mpls static binding ipv4 10.0.0.6 255.255.255.255 506
mpls static binding ipv4 10.0.0.7 255.255.255.255 507
mpls static binding ipv4 10.0.0.9 255.255.255.255 509
mpls static binding ipv4 10.0.0.10 255.255.255.255 510
mpls static binding ipv4 10.0.0.11 255.255.255.255 511
mpls static binding ipv4 10.0.0.12 255.255.255.255 512

router ospf 2
router-id 10.0.0.5
log-adjacency-changes
passive-interface Loopback0

interface Loopback0
ip address 10.0.0.5 255.255.255.255
ip ospf 2 area 0

interface FastEthernet0/0
ip address 10.1.56.5 255.255.255.0
ip ospf network point-to-point
ip ospf 2 area 0
mpls ip

R6
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 615 699 static 600 614
mpls static binding ipv4 10.0.0.2 255.255.255.255 602
mpls static binding ipv4 10.0.0.3 255.255.255.255 603
mpls static binding ipv4 10.0.0.4 255.255.255.255 604
mpls static binding ipv4 10.0.0.5 255.255.255.255 605
mpls static binding ipv4 10.0.0.7 255.255.255.255 607
mpls static binding ipv4 10.0.0.9 255.255.255.255 609
mpls static binding ipv4 10.0.0.10 255.255.255.255 610
mpls static binding ipv4 10.0.0.11 255.255.255.255 611
mpls static binding ipv4 10.0.0.12 255.255.255.255 612

router ospf 2
router-id 10.0.0.6
log-adjacency-changes
passive-interface Loopback0

interface Loopback0
ip address 10.0.0.6 255.255.255.255
ip ospf 2 area 0

interface FastEthernet0/0
ip address 10.1.56.6 255.255.255.0
ip ospf network point-to-point
ip ospf 2 area 0
mpls ip

interface FastEthernet0/1
ip address 10.1.67.6 255.255.255.0
ip ospf network point-to-point
ip ospf 2 area 0
mpls ip

R7
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 715 799 static 700 714
mpls static binding ipv4 10.0.0.2 255.255.255.255 702
mpls static binding ipv4 10.0.0.3 255.255.255.255 703
mpls static binding ipv4 10.0.0.4 255.255.255.255 704
mpls static binding ipv4 10.0.0.5 255.255.255.255 705
mpls static binding ipv4 10.0.0.6 255.255.255.255 706
mpls static binding ipv4 10.0.0.9 255.255.255.255 709
mpls static binding ipv4 10.0.0.10 255.255.255.255 710
mpls static binding ipv4 10.0.0.11 255.255.255.255 711
mpls static binding ipv4 10.0.0.12 255.255.255.255 712

router ospf 2
router-id 10.0.0.7
log-adjacency-changes
passive-interface Loopback0

interface Loopback0
ip address 10.0.0.7 255.255.255.255
ip ospf 2 area 0

interface FastEthernet0/1
ip address 10.1.67.7 255.255.255.0
ip ospf network point-to-point
ip ospf 2 area 0
mpls ip

R6#show mpls ldp discovery
Local LDP Identifier:
10.0.0.6:0
Discovery Sources:
Interfaces:
FastEthernet0/0 (ldp): xmit/recv
LDP Id: 10.0.0.5:0
FastEthernet0/1 (ldp): xmit/recv
LDP Id: 10.0.0.7:0

--------------------------------------------------------------------------

IGP + MPLS en AS100

Nota: Podemos utilizar cualquier IGP (EIGRP, RIPv2, OSPF, IS-IS), salvo que implementemos MPLS TE, en cuyo caso IS-IS y OSPF son las únicas posibilidades (Extensiones TE). Hemos elegido IS-IS por estabilidad, escalabilidad, tiempos de respuesta, no propietario, etc.…)


--------------------------------------------------------------------------
R9
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 915 999 static 900 914
mpls static binding ipv4 10.0.0.2 255.255.255.255 902
mpls static binding ipv4 10.0.0.3 255.255.255.255 903
mpls static binding ipv4 10.0.0.4 255.255.255.255 904
mpls static binding ipv4 10.0.0.5 255.255.255.255 905
mpls static binding ipv4 10.0.0.6 255.255.255.255 906
mpls static binding ipv4 10.0.0.7 255.255.255.255 907
mpls static binding ipv4 10.0.0.10 255.255.255.255 910
mpls static binding ipv4 10.0.0.11 255.255.255.255 911
mpls static binding ipv4 10.0.0.12 255.255.255.255 912

interface FastEthernet0/0
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet1/0
ip router isis
isis network point-to-point
mpls ip

router isis
mpls ldp autoconfig level-2
net 47.0100.0000.0000.0009.00
is-type level-2-only
metric-style wide
passive-interface Loopback0

R10
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 1015 1099 static 1000 1014
mpls static binding ipv4 10.0.0.2 255.255.255.255 1002
mpls static binding ipv4 10.0.0.3 255.255.255.255 1003
mpls static binding ipv4 10.0.0.4 255.255.255.255 1004
mpls static binding ipv4 10.0.0.5 255.255.255.255 1005
mpls static binding ipv4 10.0.0.6 255.255.255.255 1006
mpls static binding ipv4 10.0.0.7 255.255.255.255 1007
mpls static binding ipv4 10.0.0.9 255.255.255.255 1009
mpls static binding ipv4 10.0.0.11 255.255.255.255 1011
mpls static binding ipv4 10.0.0.12 255.255.255.255 1012

interface FastEthernet0/0
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet1/0
ip router isis
isis network point-to-point
mpls ip

router isis
mpls ldp autoconfig level-2
net 47.0100.0000.0000.0010.00
is-type level-2-only
metric-style wide
passive-interface Loopback0


R11
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 1115 1199 static 1100 1114
mpls static binding ipv4 10.0.0.2 255.255.255.255 1102
mpls static binding ipv4 10.0.0.3 255.255.255.255 1103
mpls static binding ipv4 10.0.0.4 255.255.255.255 1104
mpls static binding ipv4 10.0.0.5 255.255.255.255 1105
mpls static binding ipv4 10.0.0.6 255.255.255.255 1106
mpls static binding ipv4 10.0.0.7 255.255.255.255 1107
mpls static binding ipv4 10.0.0.9 255.255.255.255 1109
mpls static binding ipv4 10.0.0.10 255.255.255.255 1110
mpls static binding ipv4 10.0.0.12 255.255.255.255 1112

interface FastEthernet0/0
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet0/1
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet1/0
ip router isis
isis network point-to-point
mpls ip

router isis
mpls ldp autoconfig level-2
net 47.0100.0000.0000.0011.00
is-type level-2-only
metric-style wide
passive-interface Loopback0


R12
ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls label range 1215 1299 static 1200 1214
mpls static binding ipv4 10.0.0.2 255.255.255.255 1202
mpls static binding ipv4 10.0.0.3 255.255.255.255 1203
mpls static binding ipv4 10.0.0.4 255.255.255.255 1204
mpls static binding ipv4 10.0.0.5 255.255.255.255 1205
mpls static binding ipv4 10.0.0.6 255.255.255.255 1206
mpls static binding ipv4 10.0.0.7 255.255.255.255 1207
mpls static binding ipv4 10.0.0.9 255.255.255.255 1209
mpls static binding ipv4 10.0.0.10 255.255.255.255 1210
mpls static binding ipv4 10.0.0.11 255.255.255.255 1211

interface FastEthernet0/0
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet0/1
ip router isis
isis network point-to-point
mpls ip

interface FastEthernet1/0
ip router isis
isis network point-to-point
mpls ip

router isis
mpls ldp autoconfig level-2
net 47.0100.0000.0000.0012.00
is-type level-2-only
metric-style wide
passive-interface Loopback0

R11#show isis neighbors
System Id Type Interface IP Address State Holdtime Circuit Id
R9 L2 Fa0/0 10.1.119.9 UP 25 00
R10 L2 Fa1/0 10.1.110.10 UP 26 01
R12 L2 Fa0/1 10.1.112.12 UP 22 01

R12#show isis neighbors
System Id Type Interface IP Address State Holdtime Circuit Id
R9 L2 Fa1/0 10.1.129.9 UP 29 01
R10 L2 Fa0/0 10.1.102.10 UP 23 00
R11 L2 Fa0/1 10.1.112.11 UP 22 01

R11#show mpls ldp discovery
Local LDP Identifier:
10.0.0.11:0
Discovery Sources:
Interfaces:
FastEthernet0/0 (ldp): xmit/recv
LDP Id: 10.0.0.9:0
FastEthernet0/1 (ldp): xmit/recv
LDP Id: 10.0.0.12:0
FastEthernet1/0 (ldp): xmit/recv
LDP Id: 10.0.0.10:0

R12#show mpls ldp discovery
Local LDP Identifier:
10.0.0.12:0
Discovery Sources:
Interfaces:
FastEthernet0/0 (ldp): xmit/recv
LDP Id: 10.0.0.10:0
FastEthernet0/1 (ldp): xmit/recv
LDP Id: 10.0.0.11:0
FastEthernet1/0 (ldp): xmit/recv
LDP Id: 10.0.0.9:0

R11#sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
i L2 10.0.0.9/32 [115/10] via 10.1.119.9, FastEthernet0/0
i L2 10.0.0.10/32 [115/10] via 10.1.110.10, FastEthernet1/0
i L2 10.0.0.12/32 [115/10] via 10.1.112.12, FastEthernet0/1
i L2 10.1.102.0/24 [115/20] via 10.1.112.12, FastEthernet0/1
[115/20] via 10.1.110.10, FastEthernet1/0
i L2 10.1.129.0/24 [115/20] via 10.1.119.9, FastEthernet0/0
[115/20] via 10.1.112.12, FastEthernet0/1

R12#sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
i L2 10.0.0.9/32 [115/10] via 10.1.129.9, FastEthernet1/0
i L2 10.0.0.10/32 [115/10] via 10.1.102.10, FastEthernet0/0
i L2 10.0.0.11/32 [115/10] via 10.1.112.11, FastEthernet0/1
i L2 10.1.110.0/24 [115/20] via 10.1.112.11, FastEthernet0/1
[115/20] via 10.1.102.10, FastEthernet0/0
i L2 10.1.119.0/24 [115/20] via 10.1.129.9, FastEthernet1/0
[115/20] via 10.1.112.11, FastEthernet0/1

--------------------------------------------------------------------------



No hay comentarios:

Publicar un comentario